Having trouble logging in, resetting password?

22 posts / 0 new
Last post
Having trouble logging in, resetting password?

We've gotten reports that some users have had trouble logging in to Pixel Scrapper the last few weeks. For example, their password will unexpectedly not work, and when they try to reset their password they are unable to do so.

I'm trying to determine how widespread of a problem this is, and get more details on what is going wrong.

If you've had trouble please post a detailed reply letting me know as much detail as possible, and when the trouble started. Screenshots are helpful!

Thank you for your help as we try to get this issue sorted!

No: I have NOT had any trouble logging in
60% (48 votes)
Yes: I have had trouble logging in or resetting my password recently
39% (31 votes)
Total votes: 79

I think my problem is just my operating system. I use Chrome, on a windows computer. My old password autofills on the sign-in, so I have to delete it before typing in my new password. So, I guess I don't have trouble CHANGING the password - just the autofill when I log on. I do not get the usual pop-up that asks me if I want to update the password on this site...........So this just might be me, and not you.

I have the same issue with Chrome and the "remembering" of passwords - not unique to PixelScrapper though, and I haven't taken the time to research how to resolve the issue in Chrome.

@Sunny & Michelle - to fix this, go to your chrome settings (the 3 dots at the top right) and click "settings". Then scroll down and click "advanced". Continue scrolling until you see "passwords & forms" (or you can ctrl+f to find it easier) and click on "manage passwords". There, you will find all the passwords you have allowed chrome to save for you and you can delete the autofill you have for pixelscrapper. When you do so, the next time you sign into pixelscrapper, the pop-up that asks to remember your password should appear. smiley

If you are using chrome, you can go into your password manager in the app, and search for Pixelscrapper... you will see any versions of it pop up... delete all versions, or the one if it is the one there, clear your cache, and log in again... it SHOULD ask you if you want to store the new password...

Not sure if this will help or not... I have not had any problems (yet) and I do use Chrome with Windows 10. I also have my PS password set to autofill.

Thank you!

I have not had any problems (yet) and I do use firefox with Windows 10.

My LastPass was set to auto-login and when I would use that feature, I would get stuck in a login loop. I just disabled the auto-login and that seemed to work. I didn't take any screenshots because I figured it was just me.

Windows 7 / Chrome

My password was not accepted. I set up a new one. I had to do it a few times because it kept saying that the password was used already. I did get it to work. I, too, have to delete old password and type in new one each time.

FYI - I'm the same as Madge above. Windows 10, Chrome, Password Manager (Last Pass) and no issues.

Thanks for the clear and helpful info, Kayl, I fixed the password issue! You are the greatest!

I had to reset my password, about a week ago. I had it auto-saved but it was saying it was invalid. It's still setup on the auto-fill, so each time I have to delete it and type it back in. I figured that, was just part of Chrome and I'd eventually get around to resetting it somehow. I'll use the steps mentioned above and see.

Thanks Kayl, for your post. I reset my saved password on Chrome.

Chrome on MacOS10.9 with autofill. Couldn't log in, didn't receive an email when I clicked "Forgot your password" on the top of the screen. Did get an email when I clicked "Request new password" at the bottom of the screen. Resetting worked. But when typing a message here, it said "please let us know who you are" (while I was logged in) and then ate my message... smiley

Same as Melo, only I'm on Firefox with MacOS10.10.

My password is saved by Firefox but despite me hitting 'update' for the new password each time I logged on here, it didn't save it & I have to retype it. This is the only site this has happened at. It was mighty weird. It works now, but I had to physically delete Firefox's original saved information from PS to do it.

right after the site was up and running again, i had trouble logging in with my password. i have to type it in every single time. i did reset the password, but google won't remember it or ask if it wants to remember my new password. so as i said, i have to type it in every single log in.

Same as Alli, I have to type in the password every time.
Using Windows 8.1 and Chromium.

Windows 10 Home 64-bit, Chrome, AutoFill enabled, Australia... no problems, thankfully!

Thanks everyone for the replies and info--these have been very helpful!

I think the autofilling of old passwords is definitely a significant issue that is likely causing a lot of confusion and making people think that resetting their passwords is not working.

I wish we could provide an easy fix, but I'm not sure why some browsers are having issues with our form while others aren't. We will likely have to be content with warning people about this issue within the password reset emails.

For anyone having this issue, here is a guide for how to remove old saved passwords from your browser that has notes for every major web browser.

Out of curiosity, are most of you clicking on the "log in" link at the top-right corner of the site to log in?

Thank you Jordan! Yes, I do click on the "log in" link.
And this morning, my autofill was just fine, and it logged me in with no problem.
My previous two days of signing in, I had issues.
But today, magically, it's fixed! LOL
Thanks again.

I also use the "log in" link, upper right corner. No problems, and hopefully it stays that way!